This Just In! - News, X-Pert Advice

Windows Requirements for Meltdown and Spectre Updates

Four Marketing Pillars to Build a Business, Compromised Email Accounts Revealed, scammers, New Ransomware Target Identified, Networking Etiquette, Is Your Home Router Hackable?, Cerber Ransomware Uses Dropbox to Avoid Detection, Almost Perfect Phishing Technique Now Active, Two-Factor Authentication Now Compromised, World Wide Ransomware, Microsoft Defends Against WannaCry Ransomware, OneLogin Secure Signin Service Breached, Petya Ransomware Flooding the World, Cogeco Phishing Attack Targets Subscribers, Home Renovation Tips, WPA2 wireless security, Windows Requirements for Meltdown and Spectre Updates

Patches for the Meltdown and Spectre flaws are in the process of being released.  If you use Windows, here’s what you need to know.

By now, most of you have heard about the two computer chip design flaws, dubbed Meltdown and Spectre.  These flaws affect virtually all computers, smart phones and smart devices, whether you run Windows, Mac, Linux, Android or anything else, because the flaw is in the computer hardware.

To help mitigate the effects of these flaws, Microsoft has issued a major patch for Windows 7, 8 and 10; and also for their server platforms.  However, before these updates can be applied, you must have a compatible anti-virus program installed on your machine.

This spreadsheet document lists many anti-virus products and indicates whether they are compatible with the Windows patches.  If your anti-virus product is listed with a bold “N” symbol in the “Sets Registry Key” column, it means the Microsoft patch cannot be installed on your computer.

Please contact your IT support specialist if you require assistance patching your machine.  If you don’t have an IT specialist, you may contact me.

Jack Eisenberg is the owner of Safe and Secure Computing and regularly monitors cyber security developments such as this one.